Website broken on Firefox?

Discussion in 'Tutorials and User Guides' started by Haeralis, Sep 10, 2016.

Thread Status:
Not open for further replies.
  1. Haeralis

    Haeralis Puritan Board Freshman

    Hello everyone, I am experiencing an issue where Firefox just continues "loading" the page without anything happening. The loading screen remains blank forever without ever coming to the Puritanboard. No other website seems to be giving me this problem though. I thought maybe there was some kind of server maintenance, but the website is working just fine on Safari and my phone.

    Do you guys know how I can fix this problem? I hope I articulated my problem clearly enough.
     
  2. Bill The Baptist

    Bill The Baptist Puritan Board Graduate

    Yeah I can't get it to work on Firefox or Edge. It only works on Chrome or Safari.
     
  3. Berean

    Berean Puritan Board Doctor

    It's been like that going on 2 weeks now. I've tried everything including clearing cookies, cache, history, and even installing FF over itself. Nothing works. You'll just keep getting the endless loop of, "Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    I've used Chrome to get in. I did find another way in Firefox. If you have a link to the PB, such as on a homepage or a FF bookmark, right-click the link and choose "Open Link In New Private Window". That will bypass the endless redirect. You may have to login once the site opens in a Private Window. I also have no idea why this method works when using FF normally doesn't. Hope this helps.
     
  4. Semper Fidelis

    Semper Fidelis 2 Timothy 2:24-25 Staff Member

    Norm, the fact that you can get to the site by Open Link in a New Private Window, shows taht the site is not "broken on Firefox". I'm frustrated by the whole problem I created but I've gotten all the browsers that it wouldn't work on to work. Firefox included.
     
  5. NaphtaliPress

    NaphtaliPress Administrator Staff Member

    Keep clearing everything in Firefox. It eventually "took." I read somewhere that Firefox does not do this all right away when commanded; it is done in the background and eventually. It is possible it never completes? So just start, clear, close and repeat several times to see if it eventually works. That's what it took for me.
     
  6. Ed Walsh

    Ed Walsh Puritan Board Junior

    I have tried everything, and then some, and still FF only works in a "Private" browser window. I guess that's OK but it always used to work until about two weeks ago.
     
  7. Semper Fidelis

    Semper Fidelis 2 Timothy 2:24-25 Staff Member

    I also wonder if it's a DNS cache problem or that it's related to the fact that there was some sort of information cached that keeps trying to force the browser to https.
     
  8. puritanpilgrim

    puritanpilgrim Puritan Board Junior

    I can't get the website to work on safari, but it works on Firefox.
     
  9. Ed Walsh

    Ed Walsh Puritan Board Junior

    I tried purging my computers DNS cache and it did not help. Like I said I tried everything. :)
     
  10. OPC'n

    OPC'n Puritan Board Doctor

    I was having trouble getting to PB using my computer but not my phone so I knew it wasn't PB. I went to preference on safari, then to privacy, then clicked on details and cleared the cookie for PB. It didn't work, so I went back in and cleared EVERYTHING from the details button and it worked like a charm.
     
  11. Edward

    Edward Puritan Board Doctor

    It works fine on Firefox (I'm on now) on my laptop that I upgraded to Win10, but still won't work on my desktop Firefox on Win7. I use an outdated Seamonkey that works great for PB on the Win7 machine. After clearing everything a couple of times on the Firefox on the Win7, there was no improvement.

    At this point, I'd guess that the problem is probably something I blocked in my various levels of security on my main machine that I certainly keep tighter than this one. But since I can't get into it, I can't try letting various things through to see what it might be.

    My suggestion would be that anyone still having the problem try using a less secure browser.
     
  12. Haeralis

    Haeralis Puritan Board Freshman

  13. Edward

    Edward Puritan Board Doctor

    OK, I understand the new post, then. Basically, the problem was caused when the website hosting company changed some security settings. While most of us with problems were Windows/Firefox folks, there were some Android users and some Chrome users that had problems. Most were able to solve their problems by clearing the cache and cookies (it took several rounds for some folks); a few of us have been unable to resolve the problem that way. Setting up a private browsing session has worked for some folks (I need to try that one), while using other hardware or software combinations has been the 'go to' for others.

    The guy who keeps the site running has basically done everything at his end that he can; that's why I think the remaining issues are either at the user end. (I'd like to blame the ISP, but the problem appears to be machine and software specific.)
     
  14. NaphtaliPress

    NaphtaliPress Administrator Staff Member

    I think that is it in a nutshell. Haeralis cannot access the thread in the link because it is in the coffee shop and he only has 10 posts (one needs 26 posts to have access to private forums).
     
  15. Semper Fidelis

    Semper Fidelis 2 Timothy 2:24-25 Staff Member

    If you haven't tried this yet:

    Uninstall Firefox and then...
     
  16. Haeralis

    Haeralis Puritan Board Freshman

    Well, I tried deleting my DNS cache (both through the browser itself and a system wide OS X terminal command) and deleting / reinstalling Firefox. Neither of them worked, I am sorry to say. Opening a private window works, but I dislike having to log in every time I want to come to PB.

    I guess I'll just use Safari until the problem is resolved. I suppose those of us having this problem just need to remember the words of the Apostle Paul when he said in Philippians 4:

    "...I have learned how to be content with whatever I have."
     
Thread Status:
Not open for further replies.

Share This Page